summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-07-14 15:52:29 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-07-14 15:52:29 +0100
commitd029fa69db88e216faeedad6ebe0ca337a76fa6e (patch)
treebc0abf8f71099e57b0e7e7ee2050b5417af51166 /daemon/Makefile.am
parent4accf3197235300029d04d0ab637b66eaaf9f8df (diff)
downloadlibguestfs-d029fa69db88e216faeedad6ebe0ca337a76fa6e.tar.gz
libguestfs-d029fa69db88e216faeedad6ebe0ca337a76fa6e.tar.xz
libguestfs-d029fa69db88e216faeedad6ebe0ca337a76fa6e.zip
build: Add ./configure --enable-install-daemon
If enabled, then the daemon will be installed in $sbindir (eg. /usr/sbin/guestfsd). The default is off, as now. This option should be used by packagers when building the libguestfs live service.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 67589b4b..3fe8c882 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -86,7 +86,12 @@ errnostring.h: $(libsrcdir)/errnostring.h
rm -f $@
ln $< $@
+if INSTALL_DAEMON
+sbin_PROGRAMS = guestfsd
+else
noinst_PROGRAMS = guestfsd
+endif
+
guestfsd_SOURCES = \
9p.c \
actions.h \