summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorMatthew Booth <mbooth@redhat.com>2009-11-19 16:10:00 +0000
committerRichard Jones <rjones@redhat.com>2009-11-19 16:40:22 +0000
commitc477e2fb78347728aaacbbc89666dcda1481a4b9 (patch)
tree125a0e0b2596cc9f9ad44fa57199522f4c0de804 /daemon/Makefile.am
parent16c1b3164698900f52294e1396542ddd94a4cae4 (diff)
downloadlibguestfs-c477e2fb78347728aaacbbc89666dcda1481a4b9.tar.gz
libguestfs-c477e2fb78347728aaacbbc89666dcda1481a4b9.tar.xz
libguestfs-c477e2fb78347728aaacbbc89666dcda1481a4b9.zip
build: Fix inter-directory dependencies
This change adds an explicit dependency on generator.ml for every file it generates, except java files. Java is left for another time because it's considerably trickier. It also adds a build rule for src/libguestfs.la so it can be rebuilt as required from other directories. It does this by creating a top level make file, subdir-rules.mk, which can be included from sub-directories. sub-directories need to define 'generator_built' to include local files which are built by generator.ml, and they will be updated automatically. This fixes parallel make, and will automatically re-create generated files when make is run from any directory. It also fixes the problem which efad4f53 was targetting. Specifically, src/guestfs_protocol.(c|h) had an erroneous dependency on stamp-generator, and therefore generator.ml, despite not being directly created by it. This caused them to be recreated every time generator.ml ran rather than only when src/guestfs_protocol.x was updated, which cascaded into a daemon and therefore appliance update. This patch also changes the contents of the distribution tarball by including files created by rpcgen.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index d049da6d..1716c2f5 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -19,6 +19,25 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = lib tests .
+libsrcdir = $(top_builddir)/../src
+
+generator_built = \
+ actions.h \
+ stubs.c \
+ names.c
+
+.PHONY: force
+
+$(generator_built): force
+ $(MAKE) -C $(libsrcdir) stamp-generator
+
+BUILT_SOURCES = $(generator_built)
+
+EXTRA_DIST = $(BUILT_SOURCES)
+
+$(libsrcdir)/guestfs_protocol.o: force
+ $(MAKE) -C $(libsrcdir) guestfs_protocol.o
+
noinst_PROGRAMS = guestfsd
guestfsd_SOURCES = \
actions.h \
@@ -83,11 +102,8 @@ guestfsd_SOURCES = \
wc.c \
xattr.c \
zero.c \
- zerofree.c \
- $(top_builddir)/../src/guestfs_protocol.h \
- $(top_builddir)/../src/guestfs_protocol.c
+ zerofree.c
+guestfsd_LDADD = $(libsrcdir)/guestfs_protocol.o lib/libgnu.a
AM_CPPFLAGS = -I$(srcdir)/lib -Ilib
guestfsd_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
-
-LDADD = lib/libgnu.a