summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-08-17 10:35:05 +0200
committerJim Meyering <meyering@redhat.com>2009-08-17 11:40:24 +0200
commit9dd53bcb10283295d7fb5f0a3469be2984d99926 (patch)
treeb1ee4998a55dfe8fa15f4d8baa798f343e3c4435 /daemon/Makefile.am
parentc36fa40b981401cdbf61f596b804e79283d658b2 (diff)
downloadlibguestfs-9dd53bcb10283295d7fb5f0a3469be2984d99926.tar.gz
libguestfs-9dd53bcb10283295d7fb5f0a3469be2984d99926.tar.xz
libguestfs-9dd53bcb10283295d7fb5f0a3469be2984d99926.zip
daemon: enable -Werror and many gcc warnings when --enable-gcc-warnings
* daemon/m4/gnulib-cache.m4: Add two modules: manywarnings, warnings. * daemon/configure.ac: Implement --enable-gcc-warnings, and selectively disable a few warning options that are either not useful or that provoke too many warnings for now. Define and AC_SUBST WARN_CFLAGS and WERROR_CFLAGS. * daemon/Makefile.am (guestfsd_CFLAGS): Use $(WARN_CFLAGS) and $(WERROR_CFLAGS), rather than just -Wall.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index e6af0feb..097d89d8 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -81,5 +81,6 @@ guestfsd_SOURCES = \
$(top_builddir)/../src/guestfs_protocol.c
AM_CPPFLAGS = -I$(srcdir)/lib -Ilib
-guestfsd_CFLAGS = -Wall
+guestfsd_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
LDADD = lib/libgnu.a