summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-06-30 13:08:34 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-06-30 13:10:44 +0100
commitf850e1f065fb04df7cc87a921ab3c658741cc393 (patch)
tree1c42da6ab826eb851aeec3c7e902ba8c7184595b /daemon/Makefile.am
parenta10a2d46f572829fcd1f4266315106f231327d08 (diff)
downloadlibguestfs-f850e1f065fb04df7cc87a921ab3c658741cc393.tar.gz
libguestfs-f850e1f065fb04df7cc87a921ab3c658741cc393.tar.xz
libguestfs-f850e1f065fb04df7cc87a921ab3c658741cc393.zip
New commands: mknod, mkfifo, mknod_b, mknod_c and umask.
These commands are used to create block and char device nodes or FIFOs (named pipes) in the filesystem. The umask command is required also because the permissions used by mknod are masked by the umask. Also document and guarantee that the umask starts as 022.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index d69f8999..8884c6b2 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -46,6 +46,7 @@ guestfsd_SOURCES = \
initrd.c \
ls.c \
lvm.c \
+ mknod.c \
mount.c \
ntfs.c \
pingdaemon.c \
@@ -59,6 +60,7 @@ guestfsd_SOURCES = \
swap.c \
sync.c \
tar.c \
+ umask.c \
upload.c \
wc.c \
zero.c \