summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-03 12:53:00 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-03 17:44:30 +0000
commitd859c283c469b9d9124d90d0ac32024671372ed5 (patch)
tree8d8cfd99b88d86b618d1877829ad2c0ae3610d5a /daemon/Makefile.am
parent2be1648632e5e8dca06d84349314ab5e84f29e5c (diff)
downloadlibguestfs-d859c283c469b9d9124d90d0ac32024671372ed5.tar.gz
libguestfs-d859c283c469b9d9124d90d0ac32024671372ed5.tar.xz
libguestfs-d859c283c469b9d9124d90d0ac32024671372ed5.zip
daemon: Send back the errno as a string.
This changes the protocol again so that if the errno is available, it is converted to a string (like "EIO") and sent back over the protocol to the library. In this commit the library just discards the string.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 0e2ac6ef..2b585c27 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -36,7 +36,9 @@ $(generatorsrcdir)/stamp-generator: force
BUILT_SOURCES = \
$(generator_built) \
guestfs_protocol.c \
- guestfs_protocol.h
+ guestfs_protocol.h \
+ errnostring.c \
+ errnostring.h
EXTRA_DIST = $(BUILT_SOURCES) \
.gitignore
@@ -60,6 +62,13 @@ $(libsrcdir)/guestfs_protocol.c: force
$(libsrcdir)/guestfs_protocol.h: force
$(MAKE) -C $(libsrcdir) guestfs_protocol.h
+errnostring.c: $(libsrcdir)/errnostring.c
+ rm -f $@
+ ln $< $@
+errnostring.h: $(libsrcdir)/errnostring.h
+ rm -f $@
+ ln $< $@
+
noinst_PROGRAMS = guestfsd
guestfsd_SOURCES = \
actions.h \
@@ -82,6 +91,8 @@ guestfsd_SOURCES = \
dropcaches.c \
du.c \
echo_daemon.c \
+ errnostring.h \
+ errnostring.c \
ext2.c \
fallocate.c \
file.c \