summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-24 15:19:33 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-24 20:12:08 +0000
commite1aca6323e33e0dd50e23dc0d638f5789c9188e4 (patch)
tree2ae931f496aa992108d0f54bb82b8e24685918cc /configure.ac
parentc1592ac93886e7f39a6017272b2486d3f411d054 (diff)
downloadlibguestfs-e1aca6323e33e0dd50e23dc0d638f5789c9188e4.tar.gz
libguestfs-e1aca6323e33e0dd50e23dc0d638f5789c9188e4.tar.xz
libguestfs-e1aca6323e33e0dd50e23dc0d638f5789c9188e4.zip
build: Centralize all POD manipulation in 'podwrapper.sh' script.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 48d42406..352bfe86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,13 +205,16 @@ AC_CHECK_PROG([GPERF],[gperf],[gperf],[no])
test "x$GPERF" = "xno" &&
AC_MSG_ERROR([gperf must be installed])
-dnl Check for pod2man and pod2text.
+dnl Check for pod2man, pod2text, pod2html.
AC_CHECK_PROG([POD2MAN],[pod2man],[pod2man],[no])
test "x$POD2MAN" = "xno" &&
AC_MSG_ERROR([pod2man must be installed])
AC_CHECK_PROG([POD2TEXT],[pod2text],[pod2text],[no])
test "x$POD2TEXT" = "xno" &&
AC_MSG_ERROR([pod2text must be installed])
+AC_CHECK_PROG([POD2HTML],[pod2html],[pod2html],[no])
+test "x$POD2HTML" = "xno" &&
+ AC_MSG_ERROR([pod2html must be installed])
dnl Check for mkisofs.
AC_PATH_PROGS([MKISOFS],[mkisofs],[no],
@@ -837,6 +840,8 @@ AC_CONFIG_HEADERS([config.h])
dnl http://www.mail-archive.com/automake@gnu.org/msg10204.html
AC_CONFIG_FILES([appliance/update.sh],
[chmod +x appliance/update.sh])
+AC_CONFIG_FILES([podwrapper.sh],
+ [chmod +x podwrapper.sh])
AC_CONFIG_FILES([Makefile
generator/Makefile
src/Makefile fish/Makefile po/Makefile.in examples/Makefile