summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-04 10:29:25 +0100
committerRichard Jones <rjones@redhat.com>2009-04-04 10:29:25 +0100
commit64a5ae0e969754c709974104a83e6d1dbb4c2764 (patch)
treea35e26de0f9e39ad4751a9a8692dc2f6468ca47d /configure.ac
parent6d37b7698c1e2add43f0e8908e1bc30700f95f7e (diff)
downloadlibguestfs-64a5ae0e969754c709974104a83e6d1dbb4c2764.tar.gz
libguestfs-64a5ae0e969754c709974104a83e6d1dbb4c2764.tar.xz
libguestfs-64a5ae0e969754c709974104a83e6d1dbb4c2764.zip
Generate actions section in guestfs.3 man page.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef95cdde..0f7b4c39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,14 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])
])
+dnl Check for pod2man and pod2text.
+AC_CHECK_PROG([POD2MAN],[pod2man],[pod2man],[no])
+test "x$POD2MAN" = "xno" &&
+ AC_MSG_ERROR([pod2man must be installed])
+AC_CHECK_PROG([POD2TEXT],[pod2text],[pod2text],[no])
+test "x$POD2TEXT" = "xno" &&
+ AC_MSG_ERROR([pod2text must be installed])
+
dnl Check for QEMU. We only check for the basic 'qemu' program here
dnl (ie. the i386 full system qemu). But at runtime we might choose
dnl a different qemu to run, eg. qemu-system-ppc.