summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-06-23 22:02:10 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-06-23 22:02:10 +0100
commitd3270cfadd3416bd9961a2c6fb1cc131c43979da (patch)
treee56dd5040a1b90d99ac8e5f27229920527028fa2 /configure.ac
parentd2c0ee0ff7a9afdcdc1605dd464760f98d1b57d7 (diff)
downloadlibguestfs-d3270cfadd3416bd9961a2c6fb1cc131c43979da.tar.gz
libguestfs-d3270cfadd3416bd9961a2c6fb1cc131c43979da.tar.xz
libguestfs-d3270cfadd3416bd9961a2c6fb1cc131c43979da.zip
Implement libtool library versioning.
Use maximum proc_nr (MAX_PROC_NR) as a surrogate for the library ABI version, resulting in version numbers such as libguestfs.so.0.<MAX_PROC_NR>.0 for the final library. Add ABI guarantee to the documentation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec64cd3f..91e47925 100644
--- a/configure.ac
+++ b/configure.ac
@@ -497,6 +497,10 @@ fi
AM_CONDITIONAL([HAVE_INSPECTOR],
[test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
+dnl Library versioning.
+MAX_PROC_NR=`cat $srcdir/src/MAX_PROC_NR`
+AC_SUBST(MAX_PROC_NR)
+
dnl Run in subdirs.
AC_CONFIG_SUBDIRS([daemon])