summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-08-03 05:18:10 -0400
committerJim Meyering <meyering@redhat.com>2009-08-03 15:14:30 +0200
commit480a489ee4c31cb2f9c9f45941645f05b5f74c67 (patch)
treef5c37d526739c71d36499e3dc9294e3bb5199e06 /configure.ac
parent3572996364d9d24406241dee5155048440053ecf (diff)
downloadlibguestfs-480a489ee4c31cb2f9c9f45941645f05b5f74c67.tar.gz
libguestfs-480a489ee4c31cb2f9c9f45941645f05b5f74c67.tar.xz
libguestfs-480a489ee4c31cb2f9c9f45941645f05b5f74c67.zip
maint: use a git submodule for gnulib
* .gitmodules: New file, to track gnulib. * .gnulib: Submodule directory. * Makefile.am (EXTRA_DIST): Don't list config.rpath or gitlog-to-changelog. * autogen.sh: Adapt to use the new submodule. * cfg.mk: New file. (SUBDIRS): Add gnulib/lib and gnulib/tests. (dist-hook): Reflect new location of getlog-to-changelog. * configure.ac: Set build-aux/ as AUX_DIR. Invoke gl_EARLY and gl_INIT. (AC_CONFIG_FILES): Add gnulib/lib/Makefile and gnulib/tests/Makefile.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ece7da70..df466fa8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,7 @@ m4_define([libguestfs_release], [65])
m4_define([libguestfs_extra], [])
AC_INIT([libguestfs],libguestfs_major.libguestfs_minor.libguestfs_release[]libguestfs_extra)
+AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE([foreign])
AC_CONFIG_MACRO_DIR([m4])
@@ -40,6 +41,9 @@ AC_PROG_CC_STDC
AC_PROG_INSTALL
AC_PROG_CPP
+gl_EARLY
+gl_INIT
+
AC_C_PROTOTYPES
test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
@@ -594,6 +598,8 @@ AC_CONFIG_FILES([Makefile
inspector/Makefile
v2v/Makefile
libguestfs.pc
+ gnulib/lib/Makefile
+ gnulib/tests/Makefile
ocaml/META perl/Makefile.PL])
AC_OUTPUT