summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-12-06 17:44:06 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-06 22:04:27 +0000
commit53853f717c5928bc61809cc26160da118cd556fa (patch)
tree905f86bd65b9f3533a4214dd0fb7b86dab821efd /configure.ac
parent9bc15f5d98a3a17d465a94f42dc3ffb60c077293 (diff)
downloadlibguestfs-53853f717c5928bc61809cc26160da118cd556fa.tar.gz
libguestfs-53853f717c5928bc61809cc26160da118cd556fa.tar.xz
libguestfs-53853f717c5928bc61809cc26160da118cd556fa.zip
Add --with-febootstrap-yum-config.
This allows the febootstrap --yum-config option to be passed through, allowing a separate yum configuration to be used. The hope is that this will enable building in Koji.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 9 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 682fa116..f48afa7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,19 +200,15 @@ if test "x$enable_appliance" = "xyes"; then
$FEBOOTSTRAP --version >/dev/null 2>&1 ||
AC_MSG_ERROR([febootstrap >= 3.0 must be installed, your version is too old])
- dnl Build from local package files, used when building with no network
- dnl access, ie. under Koji.
- AC_MSG_CHECKING([if we should build the appliance from local packages])
- AC_ARG_WITH([local-package-directory],
- [AS_HELP_STRING([--with-local-package-directory],
- [build from local packages in dir @<:@default=no@:>@])],
- [local_package_directory=$withval],
- [local_package_directory=no])
- AC_MSG_RESULT([$local_package_directory])
- PACKAGE_DIRECTORY=
- test "x$local_package_directory" != "xno" &&
- PACKAGE_DIRECTORY="$local_package_directory"
- AC_SUBST([PACKAGE_DIRECTORY])
+ dnl Pass a febootstrap --yum-config option.
+ AC_MSG_CHECKING([if user requested febootstrap --yum-config option])
+ AC_ARG_WITH([febootstrap-yum-config],
+ [AS_HELP_STRING([--with-febootstrap-yum-config=FILE],
+ [pass febootstrap --yum-config option @<:@default=no@:>@])],
+ [FEBOOTSTRAP_YUM_CONFIG="$withval"],
+ [FEBOOTSTRAP_YUM_CONFIG=no])
+ AC_MSG_RESULT([$FEBOOTSTRAP_YUM_CONFIG])
+ AC_SUBST([FEBOOTSTRAP_YUM_CONFIG])
dnl Which distro?
dnl