summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-10-19 10:18:46 +0100
committerRichard Jones <rjones@redhat.com>2009-10-19 10:18:46 +0100
commit945b6e0a085611b45b2ab0752a66e6e60b21666c (patch)
tree003770dd080fa3644dd2a77f3ed40592f19c03a5 /configure.ac
parent854f8e0d5643e55d045f5816a520d49a057990ef (diff)
downloadlibguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.tar.gz
libguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.tar.xz
libguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.zip
Move virt tools (virt-cat, virt-edit etc) into tools/ subdirectory.
This moves the tool programs into a single directory: cat/* -> tools/virt-cat df/* -> tools/virt-df edit/* -> tools/virt-edit rescue/* -> tools/virt-rescue This in itself simplifies the build process because we only need one Makefile and one copy of 'run-locally'. 'run-*-locally' has become just 'run-locally' and takes an extra parameter which is the name of the tool, eg: run-locally cat [virt-cat params...] virt-inspector stays in its own directory, because this contains more than just a single Perl script.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 5 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 2d4cd33c..ab425612 100644
--- a/configure.ac
+++ b/configure.ac
@@ -675,18 +675,12 @@ for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper XML::Writer Locale::Tex
fi
done
if test "x$missing_perl_modules" = "xyes"; then
- AC_MSG_WARN([some Perl modules required to compile virt-cat, virt-df, virt-edit, virt-inspector and virt-rescue are missing])
+ AC_MSG_WARN([some Perl modules required to compile virt-inspector and the other virt-* tools are missing])
fi
-AM_CONDITIONAL([HAVE_CAT],
- [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
-AM_CONDITIONAL([HAVE_DF],
- [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
-AM_CONDITIONAL([HAVE_EDIT],
- [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
AM_CONDITIONAL([HAVE_INSPECTOR],
[test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
-AM_CONDITIONAL([HAVE_RESCUE],
+AM_CONDITIONAL([HAVE_TOOLS],
[test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
dnl Library versioning.
@@ -723,11 +717,8 @@ AC_CONFIG_FILES([Makefile
ruby/Makefile ruby/Rakefile
java/Makefile
haskell/Makefile
- cat/Makefile
- df/Makefile
- edit/Makefile
inspector/Makefile
- rescue/Makefile
+ tools/Makefile
libguestfs.pc
gnulib/lib/Makefile
gnulib/tests/Makefile
@@ -755,16 +746,10 @@ echo -n "Java bindings ....................... "
if test "x$HAVE_JAVA_TRUE" = "x"; then echo "yes"; else echo "no"; fi
echo -n "Haskell bindings .................... "
if test "x$HAVE_HASKELL" = "x"; then echo "yes"; else echo "no"; fi
-echo -n "virt-cat ............................ "
-if test "x$HAVE_CAT" = "x"; then echo "yes"; else echo "no"; fi
-echo -n "virt-df ............................. "
-if test "x$HAVE_DF" = "x"; then echo "yes"; else echo "no"; fi
-echo -n "virt-edit ........................... "
-if test "x$HAVE_EDIT" = "x"; then echo "yes"; else echo "no"; fi
echo -n "virt-inspector ...................... "
if test "x$HAVE_INSPECTOR" = "x"; then echo "yes"; else echo "no"; fi
-echo -n "virt-rescue ......................... "
-if test "x$HAVE_RESCUE" = "x"; then echo "yes"; else echo "no"; fi
+echo -n "virt-* tools ........................ "
+if test "x$HAVE_TOOLS" = "x"; then echo "yes"; else echo "no"; fi
echo "supermin appliance .................. $enable_supermin"
echo
echo "If any optional component is configured 'no' when you expected 'yes'"