summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-09-23 11:12:05 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-09-23 11:37:37 +0100
commit7801621dc946fe894c960e683db3cf921ef23af6 (patch)
tree32ff8764c1d73090c9030e1270088cbad5d734d5 /configure.ac
parentd15195bad9e50f4d80e84c39100a217a260fc806 (diff)
downloadlibguestfs-7801621dc946fe894c960e683db3cf921ef23af6.tar.gz
libguestfs-7801621dc946fe894c960e683db3cf921ef23af6.tar.xz
libguestfs-7801621dc946fe894c960e683db3cf921ef23af6.zip
New tool: virt-edit
Edit any file in a guest. This was possibly previously using guestfish, but having a separate command makes it simpler. The usage is simply: virt-edit mydomain /some/file It runs $EDITOR or vi on the file, and if the user changes it, uploads the result back to the VM.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7554a59b..3ad995de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -653,13 +653,15 @@ for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper XML::Writer Locale::Tex
fi
done
if test "x$missing_perl_modules" = "xyes"; then
- AC_MSG_WARN([some Perl modules required to compile virt-cat, virt-df, virt-inspector and virt-rescue are missing])
+ AC_MSG_WARN([some Perl modules required to compile virt-cat, virt-df, virt-edit, virt-inspector and virt-rescue are missing])
fi
AM_CONDITIONAL([HAVE_CAT],
[test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
AM_CONDITIONAL([HAVE_DF],
[test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
+AM_CONDITIONAL([HAVE_EDIT],
+ [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
AM_CONDITIONAL([HAVE_INSPECTOR],
[test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
AM_CONDITIONAL([HAVE_RESCUE],
@@ -701,6 +703,7 @@ AC_CONFIG_FILES([Makefile
haskell/Makefile
cat/Makefile
df/Makefile
+ edit/Makefile
inspector/Makefile
rescue/Makefile
libguestfs.pc
@@ -734,6 +737,8 @@ echo -n "virt-cat ............................ "
if test "x$HAVE_CAT" = "x"; then echo "yes"; else echo "no"; fi
echo -n "virt-df ............................. "
if test "x$HAVE_DF" = "x"; then echo "yes"; else echo "no"; fi
+echo -n "virt-edit ........................... "
+if test "x$HAVE_EDIT" = "x"; then echo "yes"; else echo "no"; fi
echo -n "virt-inspector ...................... "
if test "x$HAVE_INSPECTOR" = "x"; then echo "yes"; else echo "no"; fi
echo -n "virt-rescue ......................... "