summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-26 16:48:55 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-26 17:01:55 +0000
commit4cf4f2b66f850bb39c5bf29d3cd12ada9114d67e (patch)
treedeea09c1ce5b29125ba5b3df3c55cb313b7b2344 /configure.ac
parent18de192b0a4b71ade57acc0b6af311cc17a1bf0a (diff)
downloadlibguestfs-4cf4f2b66f850bb39c5bf29d3cd12ada9114d67e.tar.gz
libguestfs-4cf4f2b66f850bb39c5bf29d3cd12ada9114d67e.tar.xz
libguestfs-4cf4f2b66f850bb39c5bf29d3cd12ada9114d67e.zip
Remove dependency_libs from libtool *.la files.
Add a libtool wrapper which kills dependency_libs in libtool *.la files, to ensure that libtool doesn't add unnecessary extra libraries when linking. See http://lists.fedoraproject.org/pipermail/devel/2010-November/146343.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90dffb0e..0125a864 100644
--- a/configure.ac
+++ b/configure.ac
@@ -830,6 +830,11 @@ dnl Library versioning.
MAX_PROC_NR=`cat $srcdir/src/MAX_PROC_NR`
AC_SUBST(MAX_PROC_NR)
+dnl Replace libtool with a wrapper that clobbers dependency_libs in *.la files
+dnl http://lists.fedoraproject.org/pipermail/devel/2010-November/146343.html
+LIBTOOL='$(SHELL) $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
+AC_SUBST([LIBTOOL])
+
dnl Run in subdirs.
if test "x$enable_daemon" = "xyes"; then
AC_CONFIG_SUBDIRS([daemon])