summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-07 16:52:25 +0100
committerRichard Jones <rjones@redhat.com>2009-04-07 16:52:25 +0100
commit4144e2106cc70ad8f1e081b57da09f9c1e276812 (patch)
tree55022dd599e4d1583b7c93de338d7c85c15a0fe7 /configure.ac
parent21ba59ce3cbc594ce9c7aeecd4dadb8430e4042d (diff)
downloadlibguestfs-4144e2106cc70ad8f1e081b57da09f9c1e276812.tar.gz
libguestfs-4144e2106cc70ad8f1e081b57da09f9c1e276812.tar.xz
libguestfs-4144e2106cc70ad8f1e081b57da09f9c1e276812.zip
Outline OCaml bindings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0a0a4506..1359cb09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@ AC_PROG_CPP
AC_C_PROTOTYPES
test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
-AC_PROG_CC_C_O
+AM_PROG_CC_C_O
dnl Check support for 64 bit file offsets.
AC_SYS_LARGEFILE
@@ -101,7 +101,8 @@ AC_SUBST(MIRROR)
dnl Check for OCaml (optional, for OCaml bindings).
AC_PROG_OCAML
-AM_CONDITIONAL([HAVE_OCAML],[test "x$OCAMLC" != "xno"])
+AC_PROG_FINDLIB
+AM_CONDITIONAL([HAVE_OCAML],[test "x$OCAMLC" != "xno" -a "x$OCAMLFIND" != "xno"])
dnl Check for Perl (optional, for Perl bindings).
dnl XXX This isn't quite right, we should check for devel libraries.
@@ -122,7 +123,8 @@ AC_CONFIG_FILES([Makefile src/Makefile fish/Makefile examples/Makefile
images/Makefile ocaml/Makefile perl/Makefile
python/Makefile
make-initramfs.sh update-initramfs.sh
- libguestfs.spec])
+ libguestfs.spec
+ ocaml/META])
AC_OUTPUT
dnl WTF?