summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-12-06 14:31:17 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-12-06 14:32:50 +0000
commit227c9a4bca760f7f38e255f459720888a8335eeb (patch)
tree5172ae1a7135322872ccd4818c858ce598395b8d /configure.ac
parent0bb4208467dcfc49389037defe6ce7f291807901 (diff)
downloadlibguestfs-227c9a4bca760f7f38e255f459720888a8335eeb.tar.gz
libguestfs-227c9a4bca760f7f38e255f459720888a8335eeb.tar.xz
libguestfs-227c9a4bca760f7f38e255f459720888a8335eeb.zip
ubuntu: Make Ubuntu into a separate distro for the package list.
This allows us to select Ubuntu packages separately from Debian ones.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 94995f1e..912ea622 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,6 +223,9 @@ if test "x$enable_appliance" = "xyes"; then
DISTRO=REDHAT
if test -f /etc/debian_version; then
DISTRO=DEBIAN
+ if grep -q 'DISTRIB_ID=Ubuntu' /etc/lsb-release 2>/dev/null; then
+ DISTRO=UBUNTU
+ fi
fi
AC_MSG_RESULT([$DISTRO])
AC_SUBST([DISTRO])