summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-15 16:34:19 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-15 16:35:54 +0100
commitbdf7a27a790ff26664f91d95239ec33c5467bfeb (patch)
tree42fa6203b7856e2788449039d40b2d885cd02492 /configure.ac
parentb3595c5553035798b7b33d05c9326f7e8dd55e69 (diff)
downloadlibguestfs-bdf7a27a790ff26664f91d95239ec33c5467bfeb.tar.gz
libguestfs-bdf7a27a790ff26664f91d95239ec33c5467bfeb.tar.xz
libguestfs-bdf7a27a790ff26664f91d95239ec33c5467bfeb.zip
New tool virt-cat: display a file in a virtual machine.
This script is just a simpler way to cat a file from a VM. It is otherwise equivalent to using guestfish. virt-cat someguest /etc/fstab virt-cat someguest /var/log/messages | tail
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4bb7689b..f145e217 100644
--- a/configure.ac
+++ b/configure.ac
@@ -517,7 +517,7 @@ AC_CHECK_PROG([GHC],[ghc],[ghc],[no])
AM_CONDITIONAL([HAVE_HASKELL],
[test "x$GHC" != "xno"])
-dnl Check for Perl modules needed by virt-df, inspector and V2V.
+dnl Check for Perl modules needed by virt-df, inspector, V2V etc.
missing_perl_modules=no
for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper XML::Writer Locale::TextDomain; do
AC_MSG_CHECKING([for $pm])
@@ -529,9 +529,11 @@ for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper XML::Writer Locale::Tex
fi
done
if test "x$missing_perl_modules" = "xyes"; then
- AC_MSG_WARN([some Perl modules required to compile virt-df, virt-inspector and virt-v2v are missing])
+ AC_MSG_WARN([some Perl modules required to compile virt-cat, virt-df, virt-inspector and virt-v2v are missing])
fi
+AM_CONDITIONAL([HAVE_CAT],
+ [test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
AM_CONDITIONAL([HAVE_DF],
[test "x$PERL" != "xno" -a "x$missing_perl_modules" != "xyes"])
AM_CONDITIONAL([HAVE_INSPECTOR],
@@ -572,6 +574,7 @@ AC_CONFIG_FILES([Makefile
ruby/Makefile ruby/Rakefile
java/Makefile
haskell/Makefile
+ cat/Makefile
df/Makefile
inspector/Makefile
v2v/Makefile
@@ -600,6 +603,8 @@ echo -n "Java bindings ....................... "
if test "x$HAVE_JAVA_TRUE" = "x"; then echo "yes"; else echo "no"; fi
echo -n "Haskell bindings .................... "
if test "x$HAVE_HASKELL" = "x"; then echo "yes"; else echo "no"; fi
+echo -n "virt-cat ............................ "
+if test "x$HAVE_CAT" = "x"; then echo "yes"; else echo "no"; fi
echo -n "virt-df ............................. "
if test "x$HAVE_DF" = "x"; then echo "yes"; else echo "no"; fi
echo -n "virt-inspector ...................... "