summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-15 14:24:41 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-15 15:30:23 +0100
commitb3595c5553035798b7b33d05c9326f7e8dd55e69 (patch)
tree3edb92d0cba4de6af1c4c630f998880059b21e2c /configure.ac
parent9449b0fce4145a56df9d43169d61e8b2c4e41b09 (diff)
downloadlibguestfs-b3595c5553035798b7b33d05c9326f7e8dd55e69.tar.gz
libguestfs-b3595c5553035798b7b33d05c9326f7e8dd55e69.tar.xz
libguestfs-b3595c5553035798b7b33d05c9326f7e8dd55e69.zip
Make Perl strings translatable using perl-libintl.
All Perl strings are now marked as translatable using __"string" or __x("string {placeholder}", placeholder => $_). Perl strings now get copied to the PO files. The po/POTFILES.in file is now updated automagically whenever we add new *.c, *.pl or *.pm files into the repository.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3ee1102b..4bb7689b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,7 +306,7 @@ AC_CHECK_PROG([PERL],[perl],[perl],[no])
dnl Check for Perl modules that must be present to compile and
dnl test the Perl bindings.
missing_perl_modules=no
-for pm in Test::More Test::Pod Test::Pod::Coverage ExtUtils::MakeMaker; do
+for pm in Test::More Test::Pod Test::Pod::Coverage ExtUtils::MakeMaker Locale::TextDomain; do
AC_MSG_CHECKING([for $pm])
if ! perl -M$pm -e1 >/dev/null 2>&1; then
AC_MSG_RESULT([no])
@@ -519,7 +519,7 @@ AM_CONDITIONAL([HAVE_HASKELL],
dnl Check for Perl modules needed by virt-df, inspector and V2V.
missing_perl_modules=no
-for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper XML::Writer; do
+for pm in Pod::Usage Getopt::Long Sys::Virt Data::Dumper XML::Writer Locale::TextDomain; do
AC_MSG_CHECKING([for $pm])
if ! perl -M$pm -e1 >/dev/null 2>&1; then
AC_MSG_RESULT([no])