summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMasami HIRATA <msmhrt@gmail.com>2012-07-24 23:10:44 +0900
committerRichard W.M. Jones <rjones@redhat.com>2012-07-24 19:40:14 +0100
commit9519c60ce565437c91ce23ceb380f3bfe49ec224 (patch)
tree0d7471d6d678304a3b7e18597b53ee9919f457f7 /configure.ac
parent7dab20876530a7ac954b4fe809755ac12a8d8c4d (diff)
downloadlibguestfs-9519c60ce565437c91ce23ceb380f3bfe49ec224.tar.gz
libguestfs-9519c60ce565437c91ce23ceb380f3bfe49ec224.tar.xz
libguestfs-9519c60ce565437c91ce23ceb380f3bfe49ec224.zip
Mac OS X: don't check glibc-style extended printf formatters unless --enable-daemon
Signed-off-by: Masami HIRATA <msmhrt@gmail.com> RWMJ: - Test was in the wrong place (before --enable-daemon had been detected) so I moved it later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 16 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index a07e45d5..be50c484 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,22 +253,6 @@ AC_CHECK_LIB([ncurses], [UP], [], [
])
LIBS="$old_LIBS"
-dnl For modified printf in the daemon, we need glibc either (old-style)
-dnl register_printf_function or (new-style) register_printf_specifier.
-AC_CHECK_FUNC([register_printf_specifier],[
- AC_DEFINE([HAVE_REGISTER_PRINTF_SPECIFIER],[1],
- [Define to 1 if you have new-style register_printf_specifier])
- ],[
- AC_CHECK_FUNC([register_printf_function],[
- AC_DEFINE([HAVE_REGISTER_PRINTF_FUNCTION],[1],
- [Define to 1 if you have old-style register_printf_function])
- ],[
- AC_MSG_FAILURE(
-[No support for glibc-style extended printf formatters.
-
-This means you either have a very old glibc (pre-2.0) or you
-are using some other libc where this is not supported.])])])
-
dnl GNU gettext tools (optional).
AC_CHECK_PROG([XGETTEXT],[xgettext],[xgettext],[no])
AC_CHECK_PROG([MSGCAT],[msgcat],[msgcat],[no])
@@ -341,6 +325,22 @@ if test "x$enable_daemon" = "xyes"; then
fi
AC_MSG_RESULT([$DAEMON_SUPERMIN_DIR])
AC_SUBST([DAEMON_SUPERMIN_DIR])
+
+ dnl For modified printf in the daemon, we need glibc either (old-style)
+ dnl register_printf_function or (new-style) register_printf_specifier.
+ AC_CHECK_FUNC([register_printf_specifier],[
+ AC_DEFINE([HAVE_REGISTER_PRINTF_SPECIFIER],[1],
+ [Define to 1 if you have new-style register_printf_specifier])
+ ],[
+ AC_CHECK_FUNC([register_printf_function],[
+ AC_DEFINE([HAVE_REGISTER_PRINTF_FUNCTION],[1],
+ [Define to 1 if you have old-style register_printf_function])
+ ],[
+ AC_MSG_FAILURE(
+[No support for glibc-style extended printf formatters.
+
+This means you either have a very old glibc (pre-2.0) or you
+are using some other libc where this is not supported.])])])
fi
AM_CONDITIONAL([INSTALL_DAEMON],[test "x$enable_install_daemon" = "xyes"])
AM_CONDITIONAL([VALGRIND_DAEMON],[test "x$enable_valgrind_daemon" = "xyes"])