summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-06-22 09:45:06 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-06-22 10:58:00 +0100
commit823ba05ebd8f1a12574a3f154aaf7c8b4f2aeeac (patch)
treeecc7a16e8c8c7e1d5148f02a7065ae6cc094d30d /configure.ac
parent6cb74d46ba5b1c3f1edd3bfb12df9d4da2ec8a8f (diff)
downloadlibguestfs-823ba05ebd8f1a12574a3f154aaf7c8b4f2aeeac.tar.gz
libguestfs-823ba05ebd8f1a12574a3f154aaf7c8b4f2aeeac.tar.xz
libguestfs-823ba05ebd8f1a12574a3f154aaf7c8b4f2aeeac.zip
ruby: Fix libruby test.
If -lruby was not available, this used to define HAVE_LIBRUBY=0. However this meant that the later test -n "$HAVE_LIBRUBY" would be successful, whereas it should fail in this case.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6a011f3d..65a03b86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -976,11 +976,10 @@ AC_ARG_ENABLE([ruby],
AS_HELP_STRING([--disable-ruby], [Disable Ruby language bindings]),
[],
[enable_ruby=yes])
-AS_IF([test "x$enable_ruby" != "xno"],
- [
+AS_IF([test "x$enable_ruby" != "xno"],[
AC_CHECK_PROG([RUBY],[ruby],[ruby],[no])
AC_CHECK_PROG([RAKE],[rake],[rake],[no])
- AC_CHECK_LIB([ruby],[ruby_init],[HAVE_LIBRUBY=1],[HAVE_LIBRUBY=0])
+ AC_CHECK_LIB([ruby],[ruby_init],[HAVE_LIBRUBY=1],[HAVE_LIBRUBY=])
AC_SUBST([RAKE])
])
AM_CONDITIONAL([HAVE_RUBY],