summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-06-13 12:58:24 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-06-15 16:09:12 +0100
commitd6ca37a95b5ed5b7e5c8e0a54fa5a5bbf0fa2075 (patch)
tree574655c2a4581a37dadcfb3dce1793bccaa9959e /configure.ac
parent14ec52d3dc332a02dcb7d95b5f5d21fd863fc99e (diff)
downloadlibguestfs-d6ca37a95b5ed5b7e5c8e0a54fa5a5bbf0fa2075.tar.gz
libguestfs-d6ca37a95b5ed5b7e5c8e0a54fa5a5bbf0fa2075.tar.xz
libguestfs-d6ca37a95b5ed5b7e5c8e0a54fa5a5bbf0fa2075.zip
Add --enable-supermin option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1562f49..c83f8561 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,6 +179,15 @@ AC_ARG_WITH([mirror],
MIRROR="$with_mirror"
AC_SUBST(MIRROR)
+dnl Build the supermin appliance? Please see README file before
+dnl enabling this option.
+AC_ARG_ENABLE([supermin],
+ [AS_HELP_STRING([--enable-supermin],
+ [enable supermin appliance (see README) @<:@default=no@:>@])],
+ [],
+ [enable_supermin=no])
+AM_CONDITIONAL([SUPERMIN],[test "x$enable_supermin" = "xyes"])
+
dnl Readline.
AC_ARG_WITH([readline],
[AS_HELP_STRING([--with-readline],
@@ -493,6 +502,7 @@ echo -n "Haskell bindings .................... "
if test "x$HAVE_HASKELL" = "x"; then echo "yes"; else echo "no"; fi
echo -n "virt-inspector ...................... "
if test "x$HAVE_INSPECTOR" = "x"; then echo "yes"; else echo "no"; fi
+echo "supermin appliance .................. $enable_supermin"
echo
echo "If any optional component is configured 'no' when you expected 'yes'"
echo "then you should check the preceeding messages."