summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-06-16 10:55:36 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-06-16 10:55:36 +0100
commit71322ebf4ee7dfb53db344aaedd70518a3c7a552 (patch)
tree3aa90ffdb16c23551e17aee9b15dbe2fec947b03 /configure.ac
parent95b902b657dbce901f01fb97bd3cd52bd61636cb (diff)
downloadlibguestfs-71322ebf4ee7dfb53db344aaedd70518a3c7a552.tar.gz
libguestfs-71322ebf4ee7dfb53db344aaedd70518a3c7a552.tar.xz
libguestfs-71322ebf4ee7dfb53db344aaedd70518a3c7a552.zip
Don't compress the supermin base initramfs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f8ed7ba0..bee1a59d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,6 +204,22 @@ version of febootstrap.
])
fi
AC_MSG_RESULT([yes])
+
+ dnl Check febootstrap-to-initramfs accepts the --nocompress option
+ dnl (febootstrap >= 2.3).
+ AC_MSG_CHECKING([for --nocompress support in $FEBOOTSTRAP_TO_INITRAMFS])
+ out=`$FEBOOTSTRAP_TO_INITRAMFS 2>&1 ||:`
+ echo "febootstrap_to_initramfs test command output: $out" >&AS_MESSAGE_LOG_FD
+ if ! echo $out | grep -sq -- "--nocompress" ; then
+ AC_MSG_RESULT([no])
+ AC_MSG_FAILURE(
+[febootstrap-to-initramfs does not support the --nocompress option.
+
+To build the supermin appliance, you need to upgrade to the latest
+version of febootstrap.
+])
+ fi
+ AC_MSG_RESULT([yes])
fi
dnl Readline.