summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrjones <rjones>2009-03-24 14:15:13 +0000
committerrjones <rjones>2009-03-24 14:15:13 +0000
commit863d13ea1aadddc122ad82f4dad20e73231b48f2 (patch)
tree592219319af4df4a9348b53a1f8f0633d0f99020 /configure.ac
parent91df7a164befc0c9a24f85733837874da5a057ac (diff)
downloadlibguestfs-863d13ea1aadddc122ad82f4dad20e73231b48f2.tar.gz
libguestfs-863d13ea1aadddc122ad82f4dad20e73231b48f2.tar.xz
libguestfs-863d13ea1aadddc122ad82f4dad20e73231b48f2.zip
Build the initramfs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 36 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a3c21664..297ae991 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,10 +39,6 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])
])
-dnl Check for febootstrap.
-AC_CHECK_PROG([FEBOOTSTRAP],[febootstrap],[febootstrap],[no])
-test "x$FEBOOTSTRAP" = "xno" && AC_MSG_ERROR([febootstrap must be installed])
-
dnl Check for QEMU. We only check for the basic 'qemu' program here
dnl (ie. the i386 full system qemu). But at runtime we might choose
dnl a different qemu to run, eg. qemu-system-ppc.
@@ -51,10 +47,45 @@ AC_PATH_PROG([QEMU],[qemu],[no],
test "x$QEMU" = "xno" && AC_MSG_ERROR([qemu must be installed])
AC_DEFINE_UNQUOTED([QEMU],["$QEMU"],[Location of qemu binary.])
+dnl Check for febootstrap etc.
+AC_CHECK_PROG([FEBOOTSTRAP],
+ [febootstrap],[febootstrap],[no])
+test "x$FEBOOTSTRAP" = "xno" && \
+ AC_MSG_ERROR([febootstrap must be installed])
+AC_CHECK_PROG([FEBOOTSTRAP_MINIMIZE],
+ [febootstrap-minimize],[febootstrap-minimize],[no])
+test "x$FEBOOTSTRAP_MINIMIZE" = "xno" && \
+ AC_MSG_ERROR([febootstrap-minimize must be installed])
+AC_CHECK_PROG([FEBOOTSTRAP_TO_INITRAMFS],
+ [febootstrap-to-initramfs],[febootstrap-to-initramfs],[no])
+test "x$FEBOOTSTRAP_TO_INITRAMFS" = "xno" && \
+ AC_MSG_ERROR([febootstrap-to-initramfs must be installed])
+
+dnl --with-repo to specify a Fedora repository.
+AC_ARG_WITH([repo],
+ [AS_HELP_STRING([--with-repo],
+ [set name of Fedora repository @<:@default=fedora-10@:>@])],
+ [],
+ [with_repo=fedora-10])
+REPO="$with_repo"
+AC_SUBST(REPO)
+
+dnl --with-mirror to specify a local Fedora mirror.
+AC_ARG_WITH([mirror],
+ [AS_HELP_STRING([--with-mirror],
+ [set URI of a local Fedora mirror])],
+ [],
+ [with_mirror=])
+MIRROR="$with_mirror"
+AC_SUBST(MIRROR)
+
dnl Run in subdirs.
AC_CONFIG_SUBDIRS([daemon])
dnl Produce output files.
AC_CONFIG_HEADERS([config.h])
-AC_CONFIG_FILES([Makefile src/Makefile examples/Makefile])
+AC_CONFIG_FILES([Makefile src/Makefile examples/Makefile make-initramfs.sh])
AC_OUTPUT
+
+dnl WTF?
+chmod +x make-initramfs.sh \ No newline at end of file