summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-05-24 12:09:38 +0100
committerRichard Jones <rjones@redhat.com>2010-05-24 12:09:38 +0100
commit613d041c78e25dafc238696f2fe35b51e443f23b (patch)
tree9234c56739452e171a7f039fdd26e05f6d748957 /configure.ac
parent94030c5ce8b5848330e15e812a01064d5afcc6d0 (diff)
downloadlibguestfs-613d041c78e25dafc238696f2fe35b51e443f23b.tar.gz
libguestfs-613d041c78e25dafc238696f2fe35b51e443f23b.tar.xz
libguestfs-613d041c78e25dafc238696f2fe35b51e443f23b.zip
build: For development releases, print a notice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7aa383a..24a5d2b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,22 @@ AC_DEFINE([PACKAGE_VERSION_MINOR],[libguestfs_minor],[Minor version number])
AC_DEFINE([PACKAGE_VERSION_RELEASE],[libguestfs_release],[Release number])
AC_DEFINE([PACKAGE_VERSION_EXTRA],["libguestfs_extra"],[Extra version string])
+dnl Stable or unstable version?
+AC_MSG_CHECKING([if this is a stable or unstable branch of libguestfs])
+AS_IF([test "$((libguestfs_minor % 2))" -eq 0 ],[
+ AC_MSG_RESULT([stable])
+ ],[
+ AC_MSG_RESULT([unstable])
+ AC_MSG_NOTICE([
+***
+This is a development version of libguestfs. Some APIs may be unstable
+until they appear in a stable release of libguestfs (at which point
+the C API and ABI is guaranteed to remain stable forever). For
+more information about stable and development branches of libguestfs
+please see the section "LIBGUESTFS VERSION NUMBERS" in guestfs(3).
+***])
+ ])
+
dnl Die if the user tries to configure as root, see:
dnl https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
AC_MSG_CHECKING([if you are trying to configure as root])