summaryrefslogtreecommitdiffstats
path: root/capitests/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-07-31 11:55:38 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-07-31 11:55:38 +0100
commit77b2275dfcebce16ceea17ddf77a7f9d0a41c082 (patch)
tree5be0875ed858cd522a2d5b0f700986ffb9e1cf7c /capitests/Makefile.am
parent0e6e32025885286e2de39efca34ced2aaf26b3a3 (diff)
downloadlibguestfs-77b2275dfcebce16ceea17ddf77a7f9d0a41c082.tar.gz
libguestfs-77b2275dfcebce16ceea17ddf77a7f9d0a41c082.tar.xz
libguestfs-77b2275dfcebce16ceea17ddf77a7f9d0a41c082.zip
New commands: swapon-*, swapoff-*, mkswap-file.
swapon-device swapoff-device swapon-file swapoff-file swapon-label swapoff-label swapon-uuid swapoff-uuid mkswap-file
Diffstat (limited to 'capitests/Makefile.am')
-rw-r--r--capitests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/capitests/Makefile.am b/capitests/Makefile.am
index bb931e6a..71928ec1 100644
--- a/capitests/Makefile.am
+++ b/capitests/Makefile.am
@@ -35,6 +35,7 @@ TESTS_ENVIRONMENT = \
SKIP_TEST_NTFS_3G_PROBE=$(shell test -x ../initramfs/bin/ntfs-3g.probe || echo 1) \
SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi) \
SKIP_TEST_MKSWAP_U=$(shell r=1; if test -x ../initramfs/sbin/mkswap; then if ../initramfs/sbin/mkswap --help 2>&1 | grep -sq -- -U; then r=0; fi; fi; echo $$r) \
+ SKIP_TEST_SWAPON_UUID=$$SKIP_TEST_MKSWAP_U \
SKIP_TEST_SCRUB_FILE=$(shell test -x ../initramfs/usr/bin/scrub || echo 1) \
SKIP_TEST_SCRUB_DEVICE=$(shell test -x ../initramfs/usr/bin/scrub || echo 1) \
$(VG)