summaryrefslogtreecommitdiffstats
path: root/capitests/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-11-20 16:32:53 +0000
committerRichard Jones <rjones@redhat.com>2009-11-20 18:03:36 +0000
commit64de216ac7b6ef94f801e214a989c578f26956e8 (patch)
tree13b0d54d322e29fe8765488dd7503864c66bbd40 /capitests/Makefile.am
parent2d9953097b6d3b71122d444a4550047e97aee009 (diff)
downloadlibguestfs-64de216ac7b6ef94f801e214a989c578f26956e8.tar.gz
libguestfs-64de216ac7b6ef94f801e214a989c578f26956e8.tar.xz
libguestfs-64de216ac7b6ef94f801e214a989c578f26956e8.zip
availability: Skip tests when functions are not available.
Diffstat (limited to 'capitests/Makefile.am')
-rw-r--r--capitests/Makefile.am15
1 files changed, 0 insertions, 15 deletions
diff --git a/capitests/Makefile.am b/capitests/Makefile.am
index 74bfab0c..023efe4b 100644
--- a/capitests/Makefile.am
+++ b/capitests/Makefile.am
@@ -33,26 +33,11 @@ tests_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src \
$(WARN_CFLAGS) $(WERROR_CFLAGS)
tests_LDADD = $(top_builddir)/src/libguestfs.la
-# Old version of e2fsprogs which didn't support UUIDs?
-e2fs_uuid_not_supported := \
- $(shell r=1; \
- test -x ../initramfs/sbin/mkswap \
- && ../initramfs/sbin/mkswap --help 2>&1 | grep -sq -- -U \
- && r=1; \
- echo $$r)
-
TESTS = tests
TESTS_ENVIRONMENT = \
SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
- SKIP_TEST_ZEROFREE=$(shell test -x ../initramfs/usr/sbin/zerofree || echo 1) \
- SKIP_TEST_NTFS_3G_PROBE=$(shell test -x ../initramfs/bin/ntfs-3g.probe || echo 1) \
SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi) \
- SKIP_TEST_MKSWAP_U=$(e2fs_uuid_not_supported) \
- SKIP_TEST_SWAPON_UUID=$(e2fs_uuid_not_supported) \
- SKIP_TEST_MKE2JOURNAL_U=$(e2fs_uuid_not_supported) \
- SKIP_TEST_SCRUB_FILE=$(shell test -x ../initramfs/usr/bin/scrub || echo 1) \
- SKIP_TEST_SCRUB_DEVICE=$(shell test -x ../initramfs/usr/bin/scrub || echo 1) \
$(VG)
# Run the tests under valgrind.