summaryrefslogtreecommitdiffstats
path: root/capitests/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2010-11-11 23:36:04 +0000
committerRichard W.M. Jones <rjones@redhat.com>2010-11-11 23:37:54 +0000
commit59db941bf64eae2eed6a8e6451e04aa0cbec8294 (patch)
tree6d55e9cf65b833c1fc1d51751c187c5b66d9370d /capitests/Makefile.am
parent096f341714ee7d1575c93d437a8085821aa88d23 (diff)
downloadlibguestfs-59db941bf64eae2eed6a8e6451e04aa0cbec8294.tar.gz
libguestfs-59db941bf64eae2eed6a8e6451e04aa0cbec8294.tar.xz
libguestfs-59db941bf64eae2eed6a8e6451e04aa0cbec8294.zip
Check that just including <guestfs.h> on its own works.
Diffstat (limited to 'capitests/Makefile.am')
-rw-r--r--capitests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/capitests/Makefile.am b/capitests/Makefile.am
index 95afa538..0d18eaf5 100644
--- a/capitests/Makefile.am
+++ b/capitests/Makefile.am
@@ -26,6 +26,7 @@ EXTRA_DIST = $(BUILT_SOURCES)
check_PROGRAMS = \
tests \
test-command \
+ test-just-header \
test-create-handle \
test-config \
test-add-drive-opts \
@@ -33,6 +34,7 @@ check_PROGRAMS = \
TESTS = \
tests \
+ test-just-header \
test-create-handle \
test-config \
test-add-drive-opts \
@@ -65,6 +67,13 @@ test_command_LDFLAGS = -all-static
# Hand-written C API tests.
+test_just_header_SOURCES = test-just-header.c
+test_just_header_CFLAGS = \
+ -I$(top_srcdir)/src -I$(top_builddir)/src \
+ $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_just_header_LDADD = \
+ $(top_builddir)/src/libguestfs.la
+
test_create_handle_SOURCES = test-create-handle.c
test_create_handle_CFLAGS = \
-I$(top_srcdir)/src -I$(top_builddir)/src \