summaryrefslogtreecommitdiffstats
path: root/capitests/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@centos5x32.home.annexia.org>2009-07-07 19:01:45 +0100
committerRichard Jones <rjones@centos5x32.home.annexia.org>2009-07-07 19:01:45 +0100
commit291986771c95345daaf28fbcb0c54214b8e6b835 (patch)
treed5c9c28c30d925e03037e5dced8c1ae02f8fa5d4 /capitests/Makefile.am
parent8e7277fc7436d2e1eab2c395a34ced47745c6214 (diff)
downloadlibguestfs-291986771c95345daaf28fbcb0c54214b8e6b835.tar.gz
libguestfs-291986771c95345daaf28fbcb0c54214b8e6b835.tar.xz
libguestfs-291986771c95345daaf28fbcb0c54214b8e6b835.zip
RHEL 5: 'mkswap -U' not supported, check before testing it.
Diffstat (limited to 'capitests/Makefile.am')
-rw-r--r--capitests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/capitests/Makefile.am b/capitests/Makefile.am
index ab917551..7978c9fd 100644
--- a/capitests/Makefile.am
+++ b/capitests/Makefile.am
@@ -34,6 +34,7 @@ TESTS_ENVIRONMENT = \
SKIP_TEST_ZEROFREE=$(shell test -x ../initramfs/usr/sbin/zerofree || echo 1) \
SKIP_TEST_NTFS_3G_PROBE=$(shell test -x ../initramfs/bin/ntfs-3g.probe || echo 1) \
SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi) \
+ SKIP_TEST_MKSWAP_U=$(shell r=1; if test -x ../initramfs/sbin/mkswap; then if ../initramfs/sbin/mkswap --help 2>&1 | grep -sq -- -U; then r=0; fi; fi; echo $$r) \
$(VG)
# Run the tests under valgrind.