summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-07-02 21:33:51 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-07-02 21:33:51 +0100
commit7d3cccb66df63815f8230009b8d2fdf8965fbaa8 (patch)
treef3c576ddb70e7d637942ee3d61abc66ee024d660 /appliance/Makefile.am
parent373a9ad0abb09ee079da834d251a744cdbe9ae70 (diff)
downloadlibguestfs-7d3cccb66df63815f8230009b8d2fdf8965fbaa8.tar.gz
libguestfs-7d3cccb66df63815f8230009b8d2fdf8965fbaa8.tar.xz
libguestfs-7d3cccb66df63815f8230009b8d2fdf8965fbaa8.zip
Don't rebuild the whole appliance if just the /init script has been changed.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index 93e11679..03b2a7b4 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -54,12 +54,12 @@ endif
# This is for building the normal appliance:
$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist init
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
-mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
-mv $(VMLINUZ) $(VMLINUZ).bak
if ! bash make.sh; then rm -f $@; exit 1; fi
-$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd update.sh
+$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh
rm -f $@
bash update.sh
touch $@