summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-06-19 14:47:22 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-06-19 14:47:22 +0100
commitb7f39224e17eecf53ea2671122d4b3176e4d202f (patch)
tree670a78b89c91198a7143f008805c1fd5ff0740af /appliance/Makefile.am
parent677b280411cd3596051f288eecb73b5d8ae23caa (diff)
downloadlibguestfs-b7f39224e17eecf53ea2671122d4b3176e4d202f.tar.gz
libguestfs-b7f39224e17eecf53ea2671122d4b3176e4d202f.tar.xz
libguestfs-b7f39224e17eecf53ea2671122d4b3176e4d202f.zip
Move init script into a separate file.
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index 4f5eeee0..d692c7f4 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -20,7 +20,8 @@ EXTRA_DIST = \
libguestfs-supermin-helper \
kmod.whitelist \
kmod.whitelist.in \
- packagelist.in
+ packagelist.in \
+ init
# Build the root filesystem (appliance).
# Currently this is arch-dependent, so it seems like putting it in
@@ -53,7 +54,7 @@ endif
# This is for building the normal appliance:
$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist init
-mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
-mv $(VMLINUZ) $(VMLINUZ).bak
if ! bash make.sh; then rm -f $@; exit 1; fi