summaryrefslogtreecommitdiffstats
path: root/appliance/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-06-15 11:50:35 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-06-15 20:38:12 +0100
commit414aa67f2bcbbc5009b92f32611aa9196836736b (patch)
treea7090c4d47440b3979b6c0a21ba6de378acc2bb6 /appliance/Makefile.am
parenteebec43a15a5de3a5b9f1281654f9cbdd44e19cf (diff)
downloadlibguestfs-414aa67f2bcbbc5009b92f32611aa9196836736b.tar.gz
libguestfs-414aa67f2bcbbc5009b92f32611aa9196836736b.tar.xz
libguestfs-414aa67f2bcbbc5009b92f32611aa9196836736b.zip
Experimental implementation of the supermin appliance (passes most tests).
Diffstat (limited to 'appliance/Makefile.am')
-rw-r--r--appliance/Makefile.am69
1 files changed, 60 insertions, 9 deletions
diff --git a/appliance/Makefile.am b/appliance/Makefile.am
index 5dd6521e..3362992c 100644
--- a/appliance/Makefile.am
+++ b/appliance/Makefile.am
@@ -16,20 +16,37 @@
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
EXTRA_DIST = \
- make.sh update.sh
+ make.sh update.sh supermin-split.sh supermin-make.sh
# Build the root filesystem (appliance).
# Currently this is arch-dependent, so it seems like putting it in
# $(libdir) is best. When we build cross-architecture filesystems we
# should probably move them to $(datadir).
-
fsdir = $(libdir)/guestfs
-
+fs_DATA = $(APPLIANCE_FILES)
+
+# These are the resulting output files from the whole process:
+# VMLINUZ kernel for the full appliance
+# INITRAMFSIMG initramfs (ie. root fs) for the full appliance
+# For details of the supermin appliance, read the README file:
+# SUPERMINIMG initramfs (ie. partial root fs) for the supermin appliance
+# SUPERMINFILES list of missing files (the ones we will pull out of the
+# host filesystem at runtime) in the supermin appliance
+APPLIANCE_FILES = $(INITRAMFSIMG) $(VMLINUZ)
+if SUPERMIN
+APPLIANCE_FILES += $(SUPERMINIMG) $(SUPERMINFILES) kmod.whitelist
+bin_SCRIPTS = guestfs-supermin-helper
+endif
+
+# Don't change these names - they must be the same as in '*.sh' scripts.
INITRAMFSIMG = initramfs.$(REPO).$(host_cpu).img
VMLINUZ = vmlinuz.$(REPO).$(host_cpu)
+if SUPERMIN
+SUPERMINIMG = initramfs.$(REPO).$(host_cpu).supermin.img
+SUPERMINFILES = initramfs.$(REPO).$(host_cpu).supermin.hostfiles
+endif
-fs_DATA = $(INITRAMFSIMG) $(VMLINUZ)
-
+# This is for building the normal appliance:
$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist
@@ -37,15 +54,49 @@ $(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist
-mv $(VMLINUZ) $(VMLINUZ).bak
if ! bash make.sh; then rm -f $@; exit 1; fi
-$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd
+$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd update.sh
rm -f $@
bash update.sh
touch $@
-make.sh: make.sh.in
+kmod.whitelist: kmod.whitelist.in
+ grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
+
+# This is for building the supermin appliance. It has to be enabled
+# specifically with './configure --enable-supermin'. You really need
+# to read the README file.
+
+if SUPERMIN
+
+# First we need to decide which files go in and out of the supermin
+# appliance. This decision is made by 'supermin-split.sh'.
+$(SUPERMINFILES): supermin.incfiles
+supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log supermin-split.sh
+ rm -f supermin.incfiles $(SUPERMINFILES)
+ bash supermin-split.sh
+
+# Second we need to create a supermin appliance with just the included
+# files (leaving out the host files, which we'll add back at runtime).
+$(SUPERMINIMG): supermin.incfiles supermin-make.sh
+ rm -f $@
+ bash supermin-make.sh
+
+endif
+
+# This should rebuild the scripts if the input files change, although
+# it doesn't always seem to work.
+%.sh: %.sh.in
cd .. && ./config.status appliance/$@
+ chmod +x $@
+
+guestfs-supermin-helper: guestfs-supermin-helper.in
+ cd .. && ./config.status appliance/$@
+ chmod +x $@
+
+#----------------------------------------------------------------------
+# Extra rules for testing the appliance.
-# Test-boot the image.
+# Test-boot the appliance.
test-boot: emptydisk
qemu-system-$(host_cpu) \
@@ -75,7 +126,7 @@ test-boot-realistic: emptydisk
# Make clean.
-CLEANFILES = $(fs_DATA)
+CLEANFILES = $(APPLIANCE_FILES)
clean-local:
rm -rf $(top_builddir)/initramfs