summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-11-24 14:08:09 +0000
committerRichard W.M. Jones <rjones@redhat.com>2011-11-24 21:12:39 +0000
commit06fbb91d06e67f306857d10a452ac3c0b1d9357e (patch)
tree76fe796cca4c7b1555d545d3bc268f4e84a8cd71 /Makefile.am
parentec8bd1a09946db92bafad3f87669270421b80787 (diff)
downloadlibguestfs-06fbb91d06e67f306857d10a452ac3c0b1d9357e.tar.gz
libguestfs-06fbb91d06e67f306857d10a452ac3c0b1d9357e.tar.xz
libguestfs-06fbb91d06e67f306857d10a452ac3c0b1d9357e.zip
Add 'make extra-tests' rule and run extra tests.
These tests are optional, and require a special environment and tools to run. (cherry picked from commit c55bad93fbde03a3daa6058913f02098c45e55f5)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0f2bbc3f..b034b298 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,7 @@ SUBDIRS += appliance
endif
# Tests and the test-tool.
-SUBDIRS += gnulib/tests capitests caution regressions test-tool
+SUBDIRS += gnulib/tests capitests caution regressions extratests test-tool
# Guestfish.
SUBDIRS += fish
@@ -234,6 +234,11 @@ CLEANFILES = \
quickcheck:
./run test-tool/libguestfs-test-tool $(QUICKCHECK_TEST_TOOL_ARGS)
+# Run extra-tests in extratests/ subdirectory.
+
+extra-tests:
+ make -C extratests $@
+
# Make binary distribution.
BINTMPDIR = /tmp/libguestfs-bin