summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-10-05 12:25:15 +0200
committerJim Meyering <meyering@redhat.com>2009-10-05 14:16:46 +0200
commitc6b8db6493dd633bf48b13daf72cdc9c078b5f9a (patch)
tree8c51b0cb49a4b04c8839e75903549020f376cc70 /Makefile.am
parent65d61d4244b6301284e3b67e8ff23cc1374c90f2 (diff)
downloadlibguestfs-c6b8db6493dd633bf48b13daf72cdc9c078b5f9a.tar.gz
libguestfs-c6b8db6493dd633bf48b13daf72cdc9c078b5f9a.tar.xz
libguestfs-c6b8db6493dd633bf48b13daf72cdc9c078b5f9a.zip
build: avoid parallel ocaml/... build failure
A parallel build could fail due to the use in ocaml/examples of ocaml/guestfs.cmi before it was built. * Makefile.am (SUBDIRS): Add both ocaml and ocaml/examples, to ensure they're built in this order, and not in parallel. * ocaml/Makefile.am (SUBDIRS): Don't define.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fce4af2b..90c51f1b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,7 @@ SUBDIRS = gnulib/lib src daemon appliance fish po examples images \
gnulib/tests capitests regressions test-tool
if HAVE_OCAML
-SUBDIRS += ocaml
+SUBDIRS += ocaml ocaml/examples
endif
if HAVE_PERL
SUBDIRS += perl