summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-05-14 14:43:53 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-05-14 14:43:53 +0100
commit7ca3bda1660b58b82f4a11bc5637bf610a43aba6 (patch)
tree28e04ab41b1401349dc7eadb6487e501feb5451d /Makefile.am
parent17fa7abbb83024deb639aebf27686848e232e085 (diff)
downloadlibguestfs-7ca3bda1660b58b82f4a11bc5637bf610a43aba6.tar.gz
libguestfs-7ca3bda1660b58b82f4a11bc5637bf610a43aba6.tar.xz
libguestfs-7ca3bda1660b58b82f4a11bc5637bf610a43aba6.zip
Enable run-time conditional test prerequisites.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fcf5f614..50c9e7d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,7 +103,9 @@ tests_CFLAGS = \
tests_LDADD = $(top_builddir)/src/libguestfs.la
TESTS = tests
-TESTS_ENVIRONMENT = $(VG)
+TESTS_ENVIRONMENT = \
+ SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
+ $(VG)
$(TESTS): $(INITRAMFS) $(VMLINUZ)