summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-04-04 10:29:25 +0100
committerRichard Jones <rjones@redhat.com>2009-04-04 10:29:25 +0100
commit64a5ae0e969754c709974104a83e6d1dbb4c2764 (patch)
treea35e26de0f9e39ad4751a9a8692dc2f6468ca47d /Makefile.am
parent6d37b7698c1e2add43f0e8908e1bc30700f95f7e (diff)
downloadlibguestfs-64a5ae0e969754c709974104a83e6d1dbb4c2764.tar.gz
libguestfs-64a5ae0e969754c709974104a83e6d1dbb4c2764.tar.xz
libguestfs-64a5ae0e969754c709974104a83e6d1dbb4c2764.zip
Generate actions section in guestfs.3 man page.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9dc45a31..d9000610 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,9 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src daemon fish examples
-EXTRA_DIST = make-initramfs.sh
+EXTRA_DIST = \
+ make-initramfs.sh update-initramfs.sh \
+ guestfs.pod guestfs-actions.pod
# Build the root filesystem.
# Currently this is arch-dependent, so it seems like putting it in
@@ -52,6 +54,20 @@ CLEANFILES = $(fs_DATA) emptydisk
clean-local:
rm -rf initramfs
+# Manual page.
+# guestfs-actions.pod is autogenerated. There is no include mechanism
+# for POD, so we have to do it by hand.
+
+man_MANS = guestfs.3
+
+guestfs.3: guestfs.pod guestfs-actions.pod
+ sed -e '/@ACTIONS@/rguestfs-actions.pod' -e 's/@ACTIONS@//' < $< | \
+ $(POD2MAN) \
+ --section 3 \
+ -c "Virtualization Support" \
+ --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+ > $@
+
# Test-boot the image.
test-boot: emptydisk