summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-06-07 09:18:12 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-06-07 09:21:23 +0100
commitf90c01a5dc6a01284debdd0a45406f9d4a5e7159 (patch)
treef811c7c572487d4f052699e00dfe4fc304ed4d46 /Makefile.am
parent4e5d3b06fb2f366c0010ae6aa15f9dee74261917 (diff)
downloadlibguestfs-f90c01a5dc6a01284debdd0a45406f9d4a5e7159.tar.gz
libguestfs-f90c01a5dc6a01284debdd0a45406f9d4a5e7159.tar.xz
libguestfs-f90c01a5dc6a01284debdd0a45406f9d4a5e7159.zip
Enhance BUGS script.
Since RHBZ was updated, the old python-bugzilla program broke. When it was fixed, I found the (undocumented) ordering of the results from the old tool was no longer true. This commit adds a small Perl script to sort the output predictably. Now bugs are sorted by both bug state and bug number, so the output should be more stable than before. Re-enable creation of the BUGS file in 'make dist' (this reverts commit 91f3456244e7843768da659e24ce0aeeb4ebe4b0). Also the BUGS file has been updated.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 87d2d422..58e26924 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -204,8 +204,8 @@ website: $(HTMLFILES) $(TEXTFILES)
dist-hook:
$(top_srcdir)/build-aux/gitlog-to-changelog > ChangeLog
cp ChangeLog $(distdir)/ChangeLog
-# $(top_srcdir)/update-bugs.sh > BUGS-t
-# mv BUGS-t BUGS
+ $(top_srcdir)/update-bugs.sh > BUGS-t
+ mv BUGS-t BUGS
cp BUGS $(distdir)/BUGS
git log --pretty="format:%an <%ae>" | sort -u | uniq -w 10 | \
grep -v rjones | \