summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-05-09 13:40:31 +0100
committerRichard Jones <rjones@redhat.com>2009-05-09 13:40:31 +0100
commitc419731e3a04333aea7d1af7e1069221a34344a5 (patch)
tree4fbf567ef96bf2fe680cd87d11d4dc6f5cac3f67 /Makefile.am
parent09492abb6590c8b804273172dc5340705a868f95 (diff)
downloadlibguestfs-c419731e3a04333aea7d1af7e1069221a34344a5.tar.gz
libguestfs-c419731e3a04333aea7d1af7e1069221a34344a5.tar.xz
libguestfs-c419731e3a04333aea7d1af7e1069221a34344a5.zip
Add 'make valgrind' target to run tests under valgrind.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2286dd5d..8f81a076 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,9 +94,15 @@ tests_CFLAGS = \
tests_LDADD = $(top_builddir)/src/libguestfs.la
TESTS = $(check_PROGRAMS)
+TESTS_ENVIRONMENT = $(VG)
$(TESTS): $(INITRAMFS) $(VMLINUZ)
+# Run the tests under valgrind.
+
+valgrind:
+ $(MAKE) check VG="valgrind --quiet --leak-check=full"
+
# Manual pages.
# guestfs-actions.pod and guestfs-structs are autogenerated. There is
# no include mechanism for POD, so we have to do it by hand.