summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHilko Bengen <bengen@hilluzination.de>2012-01-21 22:56:51 +0100
committerRichard W.M. Jones <rjones@redhat.com>2012-01-23 09:08:33 +0000
commitb6e0552ee5359da785bd1c08cadf022190e98720 (patch)
treedc27506bf79b6fb19f1d6aba1fda8087306416b3 /Makefile.am
parent7004fafc6989efbbb1ef46723e8a91f936f16249 (diff)
downloadlibguestfs-b6e0552ee5359da785bd1c08cadf022190e98720.tar.gz
libguestfs-b6e0552ee5359da785bd1c08cadf022190e98720.tar.xz
libguestfs-b6e0552ee5359da785bd1c08cadf022190e98720.zip
Do not run appliance-related checks if not building appliance
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cf9adf32..23c0df34 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,7 @@ SUBDIRS += appliance
endif
# Tests - order is important.
+if ENABLE_APPLIANCE
SUBDIRS += tests/qemu
SUBDIRS += tests/guests
SUBDIRS += tests/c-api
@@ -41,6 +42,7 @@ SUBDIRS += tests/lvm
SUBDIRS += tests/luks
SUBDIRS += tests/md
SUBDIRS += tests/regressions
+endif
# Extra tests don't run by default. You have to do 'make extra-tests'.
SUBDIRS += tests/extra