summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-05-28 13:00:31 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-05-28 13:00:31 +0100
commita1e8cdf2a254c5eddaf525cd7c34e4c937690204 (patch)
tree4a53b93475a9f5ddd2b0159068818a530e21a797 /Makefile.am
parent4e444d53cc9497b7cb36ad35fdee825cade72b0f (diff)
downloadlibguestfs-a1e8cdf2a254c5eddaf525cd7c34e4c937690204.tar.gz
libguestfs-a1e8cdf2a254c5eddaf525cd7c34e4c937690204.tar.xz
libguestfs-a1e8cdf2a254c5eddaf525cd7c34e4c937690204.zip
Move the appliance and build scripts into new appliance/ subdirectory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am60
1 files changed, 1 insertions, 59 deletions
diff --git a/Makefile.am b/Makefile.am
index c8cf76c6..17adf1ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src daemon fish po examples images
+SUBDIRS = src daemon appliance fish po examples images
if HAVE_OCAML
SUBDIRS += ocaml
@@ -43,7 +43,6 @@ endif
EXTRA_DIST = \
config.rpath \
- make-initramfs.sh update-initramfs.sh \
guestfs.pod guestfs-actions.pod guestfs-structs.pod \
guestfish.pod guestfish-actions.pod \
html/pod.css \
@@ -65,33 +64,6 @@ EXTRA_DIST = \
contrib/febootstrap/install.sh \
test-bootbootboot.sh
-# Build the root filesystem.
-# Currently this is arch-dependent, so it seems like putting it in
-# $(libdir) is best. When we build cross-architecture filesystems we
-# should probably move them to $(datadir).
-
-fsdir = $(libdir)/guestfs
-
-INITRAMFSIMG = initramfs.$(REPO).$(host_cpu).img
-VMLINUZ = vmlinuz.$(REPO).$(host_cpu)
-
-fs_DATA = $(INITRAMFSIMG) $(VMLINUZ)
-
-$(INITRAMFSIMG) $(VMLINUZ): initramfs/fakeroot.log
-
-initramfs/fakeroot.log: make-initramfs.sh.in
- -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
- -mv $(VMLINUZ) $(VMLINUZ).bak
- if ! bash $(top_builddir)/make-initramfs.sh; then rm -f $@; exit 1; fi
-
-$(INITRAMFSIMG): initramfs/fakeroot.log daemon/guestfsd
- rm -f $@
- bash $(top_builddir)/update-initramfs.sh
- touch $@
-
-make-initramfs.sh: make-initramfs.sh.in
- ./config.status $@
-
# Tests. These are auto-generated from the test descriptions
# in the generator.
@@ -109,8 +81,6 @@ TESTS_ENVIRONMENT = \
SKIP_TEST_ZEROFREE=$(shell test -x initramfs/usr/sbin/zerofree || echo 1) \
$(VG)
-$(TESTS): $(INITRAMFS) $(VMLINUZ)
-
# Run the tests under valgrind.
valgrind:
@@ -204,34 +174,6 @@ dist-hook:
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libguestfs.pc
-# Test-boot the image.
-
-test-boot: emptydisk
- qemu-system-$(host_cpu) \
- -m 384 \
- -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
- -hda emptydisk
-
-emptydisk:
- rm -f emptydisk
- dd if=/dev/zero of=emptydisk bs=1024 count=1440
- echo 0, | sfdisk -q -C 80 -H 2 -S 18 emptydisk > /dev/null
-
-# This is a more realistic test boot command line which better
-# reflects what the library does.
-
-test-boot-realistic: emptydisk
- qemu-system-$(host_cpu) \
- -m 384 \
- -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
- -hda emptydisk \
- -append "console=ttyS0 guestfs=10.0.2.4:6666" \
- -nographic \
- -serial stdio \
- -net channel,6666:unix:/tmp/sock,server,nowait \
- -net user,vlan=0 \
- -net nic,model=virtio,vlan=0
-
# Make clean.
CLEANFILES = $(fs_DATA) emptydisk pod2htm?.tmp