summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-05-21 20:21:43 +0100
committerRichard Jones <rjones@redhat.com>2009-05-21 20:21:43 +0100
commit7784b51430c6b4dbd85c6b023191ed3bb233ad77 (patch)
tree129808f0d543cdee58a8c2babb604be85b22e1cb /Makefile.am
parent4010d56856f49b2be6f0cb227b47c48a38691a6a (diff)
downloadlibguestfs-7784b51430c6b4dbd85c6b023191ed3bb233ad77.tar.gz
libguestfs-7784b51430c6b4dbd85c6b023191ed3bb233ad77.tar.xz
libguestfs-7784b51430c6b4dbd85c6b023191ed3bb233ad77.zip
Individual tests can be skipped by setting SKIP_TEST_<CMD>[_<N>]=1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 966b5932..efde0007 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,7 +107,8 @@ tests_LDADD = $(top_builddir)/src/libguestfs.la
TESTS = tests test-bootbootboot.sh
TESTS_ENVIRONMENT = \
SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
- SKIP_ZEROFREE=$(shell test -x initramfs/usr/sbin/zerofree || echo 1) \
+ SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
+ SKIP_TEST_ZEROFREE=$(shell test -x initramfs/usr/sbin/zerofree || echo 1) \
$(VG)
$(TESTS): $(INITRAMFS) $(VMLINUZ)