summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2012-01-22 11:00:58 +0000
committerRichard W.M. Jones <rjones@redhat.com>2012-01-22 11:34:03 +0000
commit4edd061975217e4eeb09f66b8c9ea0d3fb17edba (patch)
tree8f30b4646e13d53a841bc7383d24d49623253ed3 /Makefile.am
parentde5d416fc7b3213641b035288c1df199346e9020 (diff)
downloadlibguestfs-4edd061975217e4eeb09f66b8c9ea0d3fb17edba.tar.gz
libguestfs-4edd061975217e4eeb09f66b8c9ea0d3fb17edba.tar.xz
libguestfs-4edd061975217e4eeb09f66b8c9ea0d3fb17edba.zip
website: Rebuild the HTML manual pages from scratch.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 839379ae..cf9adf32 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,6 +170,7 @@ EXTRA_DIST = \
run \
update-bugs.sh
+# The website.
HTMLFILES = \
html/guestfs.3.html \
html/guestfs-examples.3.html \
@@ -209,7 +210,11 @@ TEXTFILES = BUGS README RELEASE-NOTES ROADMAP TODO
WEBSITEDIR = $(HOME)/d/redhat/websites/libguestfs
+# For reasons not fully understood, we need to rebuild all the
+# man pages and HTMLFILES from scratch here.
website: $(HTMLFILES) $(TEXTFILES)
+ find -name 'stamp-*.pod' -delete
+ $(MAKE)
cp $(HTMLFILES) $(WEBSITEDIR)
for f in $(TEXTFILES); do cp $$f $(WEBSITEDIR)/$$f.txt; done
cd $(WEBSITEDIR) && \