summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-15 14:24:41 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-15 15:30:23 +0100
commitb3595c5553035798b7b33d05c9326f7e8dd55e69 (patch)
tree3edb92d0cba4de6af1c4c630f998880059b21e2c /Makefile.am
parent9449b0fce4145a56df9d43169d61e8b2c4e41b09 (diff)
downloadlibguestfs-b3595c5553035798b7b33d05c9326f7e8dd55e69.tar.gz
libguestfs-b3595c5553035798b7b33d05c9326f7e8dd55e69.tar.xz
libguestfs-b3595c5553035798b7b33d05c9326f7e8dd55e69.zip
Make Perl strings translatable using perl-libintl.
All Perl strings are now marked as translatable using __"string" or __x("string {placeholder}", placeholder => $_). Perl strings now get copied to the PO files. The po/POTFILES.in file is now updated automagically whenever we add new *.c, *.pl or *.pm files into the repository.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe960b73..3f276930 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,6 +149,15 @@ dist-hook:
./gitlog-to-changelog > ChangeLog
cp ChangeLog $(distdir)/ChangeLog
+# Update the list of translatable files in po/POTFILES.in.
+all-local:
+ find -name '*.c' -o -name '*.pl' -o -name '*.pm' | \
+ grep -v '/blib/' | \
+ grep -v '/capitests/' | \
+ grep -v '/examples/' | \
+ sort | \
+ sed 's,^\./,,' > $(srcdir)/po/POTFILES.in
+
# Pkgconfig.
pkgconfigdir = $(libdir)/pkgconfig