summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-10-13 15:37:56 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-10-13 22:36:56 +0100
commit9e382f1ae33ed25f012596b801e9cc4a440cb74b (patch)
tree61afe205dd6145d19e9b9393d121df0a46b53869 /Makefile.am
parent189c3d6ac1e3fbd4f8ffbaafdc36b8ad00961284 (diff)
downloadlibguestfs-9e382f1ae33ed25f012596b801e9cc4a440cb74b.tar.gz
libguestfs-9e382f1ae33ed25f012596b801e9cc4a440cb74b.tar.xz
libguestfs-9e382f1ae33ed25f012596b801e9cc4a440cb74b.zip
virt-sysprep: Switch to using guestmount, add more features.
This switches virt-sysprep to use guestmount instead of guestfish. This makes the script a little bit easier to modify for sysadmins. This commit also adds: - dhcp-client-state - dhcp-server-state - logfiles - random-seed - smolt-uuid - yum-uuid SELinux relabelling, and a section on security in the manual page.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d44c76a..5170ec8c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,9 +38,6 @@ SUBDIRS += fish
# virt-tools in C.
SUBDIRS += align cat df edit inspector rescue
-# virt-tools in shell.
-SUBDIRS += clone
-
# Language bindings.
if HAVE_PERL
SUBDIRS += perl perl/examples
@@ -88,6 +85,11 @@ if HAVE_FUSE
SUBDIRS += fuse
endif
+# virt-tools in shell. This uses guestmount.
+if HAVE_FUSE
+SUBDIRS += clone
+endif
+
# po-docs must come after tools, inspector.
if HAVE_PO4A
SUBDIRS += po-docs