summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-11-24 15:19:08 +0000
committerRichard Jones <rjones@redhat.com>2009-11-24 16:01:11 +0000
commit299d5b9dd260d47ac5121126ecd0e3f7bc4830b5 (patch)
tree934509c2fdefa3fde1676352a752af53e27ef7b1 /Makefile.am
parent9b6185b9bf8147e20563608b23eaafce9c5edc2f (diff)
downloadlibguestfs-299d5b9dd260d47ac5121126ecd0e3f7bc4830b5.tar.gz
libguestfs-299d5b9dd260d47ac5121126ecd0e3f7bc4830b5.tar.xz
libguestfs-299d5b9dd260d47ac5121126ecd0e3f7bc4830b5.zip
New tool: virt-list-filesystems
Use this program as a convenient way to list the filesystems available in a disk image or libvirt guest. Example: $ virt-list-filesystems /dev/vg_trick/Debian5x64 /dev/debian5x64/home /dev/debian5x64/root /dev/debian5x64/tmp /dev/debian5x64/usr /dev/debian5x64/var /dev/sda1 This is designed to make it easier for novices to use guestfish and guestmount. In particular with guestmount this acts as a way to get a list of filesystems to use with the '-m' option. ie: $ virt-list-filesystems unknowndisk.img /dev/sda1 /dev/sda2 $ guestmount -a unknowndisk.img -m /dev/sda1 /mnt
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bbdb0ed4..d0ad5cad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,6 +170,7 @@ HTMLFILES = \
html/virt-df.1.html \
html/virt-edit.1.html \
html/virt-inspector.1.html \
+ html/virt-list-filesystems.1.html \
html/virt-ls.1.html \
html/virt-rescue.1.html \
html/virt-tar.1.html \
@@ -205,6 +206,7 @@ all-local:
-name 'virt-df' -o \
-name 'virt-edit' -o \
-name 'virt-inspector' -o \
+ -name 'virt-list-filesystems' -o \
-name 'virt-ls' -o \
-name 'virt-rescue' -o \
-name 'virt-tar' -o \