summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-09-02 14:54:44 +0100
committerRichard Jones <rjones@redhat.com>2010-09-02 20:37:06 +0100
commit8c48f5ae2ea5221f6c53934262c5505f4b20ca8c (patch)
treeff5877505fb20f2fc06b2a227239b1ed90db2542 /Makefile.am
parent1193df7e0abfa25a78de246b6be148ec09470623 (diff)
downloadlibguestfs-8c48f5ae2ea5221f6c53934262c5505f4b20ca8c.tar.gz
libguestfs-8c48f5ae2ea5221f6c53934262c5505f4b20ca8c.tar.xz
libguestfs-8c48f5ae2ea5221f6c53934262c5505f4b20ca8c.zip
Allow manual pages and POD files to be translated.
This uses the optional po4a package to split these files into PO files for translation, and reassemble afterwards. Note this creates an extra pot file (po-docs/libguestfs-docs.pot). We don't (yet) combine this with the main po/libguestfs.pot file. The 'libguestfs-docs.pot' file included in this commit is not the real thing, just a short cut down snippet for testing. The real thing is created if you update one of the dependent files and rebuild. Note also the dummy ja.po, for testing the principles.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a33c91c3..085202b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@ include $(top_srcdir)/subdir-rules.mk
ACLOCAL_AMFLAGS = -I m4
# Basic source for the library.
-SUBDIRS = gnulib/lib images src examples po
+SUBDIRS = gnulib/lib images src examples po po-docs
if ENABLE_DAEMON
SUBDIRS += daemon
@@ -181,6 +181,7 @@ all-local:
grep -v '/guestfs_protocol.c' | \
grep -v '/rc_protocol.c' | \
grep -v 'appliance/debian/root' | \
+ grep -v '^po-docs/' | \
LC_ALL=C sort | \
sed 's,^\./,,' > po/POTFILES.in