summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2009-10-19 10:18:46 +0100
committerRichard Jones <rjones@redhat.com>2009-10-19 10:18:46 +0100
commit945b6e0a085611b45b2ab0752a66e6e60b21666c (patch)
tree003770dd080fa3644dd2a77f3ed40592f19c03a5 /Makefile.am
parent854f8e0d5643e55d045f5816a520d49a057990ef (diff)
downloadlibguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.tar.gz
libguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.tar.xz
libguestfs-945b6e0a085611b45b2ab0752a66e6e60b21666c.zip
Move virt tools (virt-cat, virt-edit etc) into tools/ subdirectory.
This moves the tool programs into a single directory: cat/* -> tools/virt-cat df/* -> tools/virt-df edit/* -> tools/virt-edit rescue/* -> tools/virt-rescue This in itself simplifies the build process because we only need one Makefile and one copy of 'run-locally'. 'run-*-locally' has become just 'run-locally' and takes an extra parameter which is the name of the tool, eg: run-locally cat [virt-cat params...] virt-inspector stays in its own directory, because this contains more than just a single Perl script.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index c4a84f78..73d4f63b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,9 +26,14 @@ SUBDIRS = gnulib/lib src daemon appliance fish po examples images \
if HAVE_PERL
SUBDIRS += perl
endif
+
if HAVE_INSPECTOR
SUBDIRS += inspector
endif
+if HAVE_TOOLS
+SUBDIRS += tools
+endif
+
if HAVE_OCAML
SUBDIRS += ocaml ocaml/examples
endif
@@ -44,18 +49,6 @@ endif
if HAVE_HASKELL
SUBDIRS += haskell
endif
-if HAVE_DF
-SUBDIRS += df
-endif
-if HAVE_CAT
-SUBDIRS += cat
-endif
-if HAVE_RESCUE
-SUBDIRS += rescue
-endif
-if HAVE_EDIT
-SUBDIRS += edit
-endif
EXTRA_DIST = \
guestfs.pod guestfs-actions.pod guestfs-structs.pod \