summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rich@koneko.home.annexia.org>2010-03-21 16:03:16 +0000
committerRichard Jones <rich@koneko.home.annexia.org>2010-03-22 10:41:44 +0000
commitef044690c54deb597bfe706cb88849dda5ebe8fc (patch)
treea7ec03eebe4646bd7f40684ebd76226dc85efc65 /Makefile.am
parentb7d59e2cdaa73b42a2063a0653151bae20497074 (diff)
downloadlibguestfs-ef044690c54deb597bfe706cb88849dda5ebe8fc.tar.gz
libguestfs-ef044690c54deb597bfe706cb88849dda5ebe8fc.tar.xz
libguestfs-ef044690c54deb597bfe706cb88849dda5ebe8fc.zip
configure: Add --disable-daemon and --disable-appliance options.
Use these on any platforms where you don't want or need to build the daemon/appliance combination.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c1fc85d6..df34d38b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,8 +19,17 @@ include $(top_srcdir)/subdir-rules.mk
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = gnulib/lib src daemon appliance fish po examples images \
- gnulib/tests capitests regressions test-tool
+SUBDIRS = gnulib/lib src
+
+if ENABLE_DAEMON
+SUBDIRS += daemon
+endif
+if ENABLE_APPLIANCE
+SUBDIRS += appliance
+endif
+
+SUBDIRS += fish po examples images
+SUBDIRS += gnulib/tests capitests regressions test-tool
# NB: Must build inspector directory after perl and before ocaml.
# We could relax this if we combined the inspector_generator with