summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2009-05-28 13:15:34 +0100
committerRichard W.M. Jones <rjones@redhat.com>2009-05-28 13:15:34 +0100
commite2206733d1287f5809dbde954f3eb64420471b0d (patch)
tree0f8efec3202e0577e581aa87ac443be82b38ad71 /Makefile.am
parenta1e8cdf2a254c5eddaf525cd7c34e4c937690204 (diff)
downloadlibguestfs-e2206733d1287f5809dbde954f3eb64420471b0d.tar.gz
libguestfs-e2206733d1287f5809dbde954f3eb64420471b0d.tar.xz
libguestfs-e2206733d1287f5809dbde954f3eb64420471b0d.zip
Move C API tests out of root build dir into 'capitests' subdir.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am35
1 files changed, 2 insertions, 33 deletions
diff --git a/Makefile.am b/Makefile.am
index 17adf1ca..55b20ba9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src daemon appliance fish po examples images
+SUBDIRS = src daemon appliance fish po examples images capitests
if HAVE_OCAML
SUBDIRS += ocaml
@@ -47,7 +47,6 @@ EXTRA_DIST = \
guestfish.pod guestfish-actions.pod \
html/pod.css \
HACKING TODO \
- tests.c \
libguestfs.pc libguestfs.pc.in \
gitlog-to-changelog \
recipes/LICENSE \
@@ -57,40 +56,10 @@ EXTRA_DIST = \
recipes/*.example \
html/recipes.css \
make-recipes.sh \
- test-cleanup.sh \
contrib/README \
contrib/febootstrap/install.title \
contrib/febootstrap/install.html \
- contrib/febootstrap/install.sh \
- test-bootbootboot.sh
-
-# Tests. These are auto-generated from the test descriptions
-# in the generator.
-
-check_PROGRAMS = tests test-command
-
-tests_SOURCES = tests.c
-tests_CFLAGS = \
- -I$(top_builddir)/src -Wall
-tests_LDADD = $(top_builddir)/src/libguestfs.la
-
-TESTS = tests test-bootbootboot.sh
-TESTS_ENVIRONMENT = \
- SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
- SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
- SKIP_TEST_ZEROFREE=$(shell test -x initramfs/usr/sbin/zerofree || echo 1) \
- $(VG)
-
-# Run the tests under valgrind.
-
-valgrind:
- $(MAKE) check VG="valgrind --quiet --leak-check=full"
-
-# This binary must be statically linked. It is used for testing
-# the "guestfs_command" and "guestfs_command_lines" functions.
-
-test_command_SOURCES = test-command.c
-test_command_LDFLAGS = -all-static
+ contrib/febootstrap/install.sh
# Manual pages.
# guestfs-actions.pod and guestfs-structs are autogenerated. There is