summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@trick.home.annexia.org>2009-07-15 16:34:19 +0100
committerRichard Jones <rjones@trick.home.annexia.org>2009-07-15 16:35:54 +0100
commitbdf7a27a790ff26664f91d95239ec33c5467bfeb (patch)
tree42fa6203b7856e2788449039d40b2d885cd02492 /Makefile.am
parentb3595c5553035798b7b33d05c9326f7e8dd55e69 (diff)
downloadlibguestfs-bdf7a27a790ff26664f91d95239ec33c5467bfeb.tar.gz
libguestfs-bdf7a27a790ff26664f91d95239ec33c5467bfeb.tar.xz
libguestfs-bdf7a27a790ff26664f91d95239ec33c5467bfeb.zip
New tool virt-cat: display a file in a virtual machine.
This script is just a simpler way to cat a file from a VM. It is otherwise equivalent to using guestfish. virt-cat someguest /etc/fstab virt-cat someguest /var/log/messages | tail
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f276930..b425ddd5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,9 @@ endif
if HAVE_DF
SUBDIRS += df
endif
+if HAVE_CAT
+SUBDIRS += cat
+endif
EXTRA_DIST = \
config.rpath \
@@ -129,6 +132,7 @@ html/recipes.html: $(wildcard recipes/*.sh) $(wildcard recipes/*.html) $(wildcar
mv $@-t $@
HTMLFILES = html/guestfs.3.html html/guestfish.1.html \
+ html/virt-cat.1.html \
html/virt-df.1.html \
html/virt-inspector.1.html \
html/virt-v2v.1.html \