summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Jones <rjones@redhat.com>2010-04-17 15:46:08 +0100
committerRichard Jones <rjones@redhat.com>2010-04-17 15:46:08 +0100
commit09a0427448b1f4328b9246d4d8a26610bb5228c8 (patch)
tree921c0ff5155feb545b022108698aaadbad723ab0 /Makefile.am
parent2a9abc7791a12af07ec2dada4b3a9a16eb452dca (diff)
downloadlibguestfs-09a0427448b1f4328b9246d4d8a26610bb5228c8.tar.gz
libguestfs-09a0427448b1f4328b9246d4d8a26610bb5228c8.tar.xz
libguestfs-09a0427448b1f4328b9246d4d8a26610bb5228c8.zip
Build top-level directories in a more logical order.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 20 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 44fc8933..2fde7ffe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,8 @@ include $(top_srcdir)/subdir-rules.mk
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = gnulib/lib src
+# Basic source for the library.
+SUBDIRS = gnulib/lib images src examples po
if ENABLE_DAEMON
SUBDIRS += daemon
@@ -28,24 +29,16 @@ if ENABLE_APPLIANCE
SUBDIRS += appliance
endif
-SUBDIRS += fish po examples images
+# Tests and the test-tool.
SUBDIRS += gnulib/tests capitests regressions test-tool
+# Guestfish.
+SUBDIRS += fish
+
+# Language bindings.
if HAVE_PERL
SUBDIRS += perl
endif
-
-if HAVE_INSPECTOR
-SUBDIRS += inspector
-endif
-if HAVE_TOOLS
-SUBDIRS += tools
-endif
-
-if HAVE_FUSE
-SUBDIRS += fuse
-endif
-
if HAVE_OCAML
SUBDIRS += ocaml ocaml/examples
endif
@@ -62,6 +55,19 @@ if HAVE_HASKELL
SUBDIRS += haskell
endif
+# Virt-inspector, tools and guestmount.
+if HAVE_INSPECTOR
+SUBDIRS += inspector
+endif
+
+if HAVE_TOOLS
+SUBDIRS += tools
+endif
+
+if HAVE_FUSE
+SUBDIRS += fuse
+endif
+
EXTRA_DIST = \
$(generator_built) \
html/pod.css \