summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2011-09-23 11:25:27 +0100
committerRichard W.M. Jones <rjones@redhat.com>2011-09-24 18:19:46 +0100
commite576d2ec46adefa14b2d9c3d51e7f19a7810f909 (patch)
treec52616ebd896459d83e7724e990a7b1440704e52 /configure.ac
parentb8cea4656e5bf1b9e7bb2274ef968ea42b10e0df (diff)
downloadfebootstrap-e576d2ec46adefa14b2d9c3d51e7f19a7810f909.tar.gz
febootstrap-e576d2ec46adefa14b2d9c3d51e7f19a7810f909.tar.xz
febootstrap-e576d2ec46adefa14b2d9c3d51e7f19a7810f909.zip
Use ext2fs_close2 API if available to avoid unnecessary fsync.
This saves over 5 seconds during the slow path construction of the appliance. The ext2fs_close2 API is present in the e2fsprogs 'next' branch and will be in a later e2fsprogs release (thanks Ted Ts'o).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a75a581..23c876b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,7 @@ old_LIBS="$LIBS"
AC_CHECK_LIB([ext2fs],[ext2fs_file_open2],[],[
AC_MSG_FAILURE([libext2fs library not found (part of e2fsprogs)])
])
+AC_CHECK_FUNCS([ext2fs_close2])
LIBS="$old_LIBS"
AC_CHECK_HEADER([ext2fs/ext2fs.h],[],[